Device Compatibility

SwingTracker 3.6.1 is compatibile with these Apple devices when running iOS 9.0 or later.

iPad 2

iPad 3rd Gen

iPad 4th Gen

iPad Air

iPad Air 2

iPad Mini

iPad Mini 2

iPad Mini 3

iPhone 7

iPhone SE

iPhone 6 Plus

iPhone 6

iPhone 5s

iPhone 5

iPhone 4s

SwingTracker 3.6.1 is not currently compatible with Android Devices. The DK team is hard at work on developing SwingTracker support for our Android friends!